Wikia

Adobe Premiere Pro

Error:Error compiling movie

Talk0
1,130pages on
this wiki

IssueEdit

  • Premiere Pro produces the message "Error compiling movie. Unknown error."
  • This message is generally followed by the error message, "Sorry, a serious error has occurred that requires Adobe Premiere Pro to shut down. We will attempt to save your current project."

Most likely Solution Edit

Clear you temporary folder. Do this manually (as described below) or use Pirform's cCleaner to clear your temporary files automatically. You may need a larger HDD to export the file.

Possible SolutionsEdit

This error message used to be related to simply not having enough available disk space in CS3, but in CS4 it could be a lot of different issues. Do yourself a favor and verify that you do indeed have enough available disk space to render out an AVI file. Also, because the Adobe Media Encoder makes a copy of your project file to the Windows Temp folder, make sure that you've deleted all the accumulated junk out of the Temp directory. You can do this by typying %Temp% from the Run (XP) or Start Search (Vista) line. Select all the files in the Temp directory and delete them. You'll find that some files can't be deleted (because they're in use) but you should be able to get rid of 99% of them.

{C}If this doesn't help, then you can try to troubleshoot your timelines and assets or try a work around. If exporting as AVI and using the Export of Encore feature failed, try exporting through AME using one of the MPEG2 - DVD export presets (this would be the work around). Troubleshooting your timelines can be pretty time intensive. Make a copy of your project so that you can experiment with the copy but leave the original intact. Export each of your timelines until you find one (or more) that fail. Delete half the media and assets from the timeline and try to export again. If the export works, you know the problem was in the last half of the timeline. Undo your deletion and then delete the last qtr of the timeline and try the export again. If the export fails, delete half of what remains in the timeline and try the export again. Keep using this trial and error method to see if you can locate the asset or problem in the timeline that is causing the failure. If you can locate the problem asset, you may be able to recapture the file or convert it to a new file type to resolve the problem.


  • Opening a read-only project has reportedly caused this.
  • Make sure the folder path for the exported file only contains letters and numbers and NOT special characters. For example, change "Johnson's Wedding" to "Johnsons Wedding". Spaces are alright.
I created a new sequence in the same project, then selected all the contents from the old sequence, and then copied them to the newly created sequence. Voila! Everything was corrected.
The "error compiling movie, unknown error" problem that you are getting when export as Quicktime means that you don't have enough available hard drive space to export the gigantic file you're trying to export. You've got three choices here:

1. Choose a hard drive that has enough available disk space, or clean up enough space on the existing drive.
2. Use a compressor to make the QT file smaller.
3. Export out a smaller section of the file.

You get this same error message when tring to create an FLV file in PPro when you've got limited disk space. The problem there is that PPro first makes and uncompressed QT file then uses QT to convert the file to FLV.

Free up some disk space and try it again.
  • Abdullah A. said:
"I have tried many of the possible reasons, It took me a very long time, However, I did find the answear. My problem was; I had a very small corrupted graphic. I did not know it was corrupted at first, I just assumed. It finally renders now"
  • Anonymous said:
I had the same problem. It was in the custom settings (1280*720 HD video / 24fps). Finaly I tried new project with predefined settings (1280*720 / 30fps) and exporting was OK - problem fixed ;)
For me the problem was in Preferences: Scratch Disks, all the file directories had a ? in them. I set them to the right path and was able to save my file.
  • Anonymous said:
It turned out I had corrupt media files in my sequence. I used this tool to locate them quickly.
  • Anonymous said:

Just copy what you want to render in a new project, and rendering will work.

==

  • Anonymous said:

Disable GPU acceleration. For some reason this was not a problem for me until I tried to render or export. ==

  • Anonymous:

If the compiling stops all the time at the same point (you can see it in the preview of the media encoder), then it can be a non-working effect in that specific clip. For me it was a color correction in two clips. Removed the color correction and it worked. Quite strange, because it only happened when going to H.264.

Disable frame blending in the clips on the timeline. Took me a couple of hours to find this solution.Edit

|}

After upgrading from CS5 to CS5.5 I started getting loads of "error compiling movie - Uknown Error" messages. I checked my clips, checked audio, checked for any gaps in editing , scratch disks size, temp directory etc.

My final solution was to load the CS5.5 project into CS5 then the sequences rendered fine.

I havent used CS5.5 since and after all the readings I decided to look at the last project which failed in CS5.5


It was a multicam sequence where initially when I had synced the clips I started of by linear editing for a few mins then go to the part where multiple streams were added for the multicam bit. Once everything was synced and I had rebdered out a single audio file for audio 1 chanelle I made the multicam sequence, imported the edited an synced sequence into the multicam sequence, performed the multicam for that section of the sequence and then went to render out.

Error compiling movie unknown error! now the first part of the multicam sequence was just linear editing from the other squence however the error was happening at the beginning so must have been in that section, I trwaled through it nada, everything was fine. Heres the funny bit, as this was linear editing I copies the bit up to the multcamed synced section, went to the edited mukltican sequence and pasted the actual linear edit over the multicam single sequence edit bit and PRESTO, the whole thing rendered out fine?

So It now seems there is something going rye with the program CS5.5 when a single edited sequence is being transfered to a multicam sequence, so there is the solution Folks simply copy and paste the actual edited bit from the original over to your multicam edited sequence and bingo.


I was going crazy with this problem, but after I disabled all the frame blendings, IT WORKED!


Disable Frame Blending!Edit

Helped me too. Normal project, no multicamera, same project rendered fine in 5.0. error message and stopped compiling movie in 5.5... I found the spot through rendering the timeline throug enterkey - I analyzed the sequence: it was the frameblending. disabled and worked. anyway I need the blending while there is a slomotion...


FIX IT ADOBE !

See AlsoEdit

New project, import the old project in to it, worked fine with me. I found this trick after 4hours of trying. Only way to work it out.


Thanks.


Markus

Around Wikia's network

Random Wiki