Fandom

Adobe Premiere Pro

Xvid

1,132pages on
this wiki
Add New Page
Talk0 Share

Ad blocker interference detected!


Wikia is a free-to-use site that makes money from advertising. We have a modified experience for viewers using ad blockers

Wikia is not accessible if you’ve made further modifications. Remove the custom ad blocker rule(s) and the page will load as expected.

  • Detailed Xvid information
  • Input: Xvid uses temporal compression, which is not suitable for editing. Using Xvid files as source clips will cause you a lot of grief. Convert them to “uncompressed AVI” or “DV AVI” before importing them into Premiere Pro.
  • Output: Export your Premiere Pro project to an “uncompressed AVI” or “DV AVI” file and then use other software to encode to Xvid. Another possibility is to install Frameserver plugin (Debugmode Frameserver) and frameserve to another program, such as VirtualDub. One would File->Export->Movie and choose Frameserve as output format. This approach saves disk space (no need for an extra large file).
    • Here is step-by-step guide provided by Uri L Blumenthal:
      • You install "Debug Frameserver" plugin. See DebugMode Web site
      • When you export to movie, you select Frameserver as video type, set whatever else you need (but not the video compression yet!), and click OK (or whatever - try it and you'll see).
      • It will prompt you for a file name - you give it a new (temporary) file name (it will not take much space on disk anyway). A dialog pops up, with the option to "Stop Serving".
      • You start VirtualDub (installed from VirtualDub Web site), and do "Open Video File" opening the file you've created during the previous step of this instruction (32 bit VirtualDub needed!)
      • You go to Video->Compression and set it to DivX, Xvid or whatever you want.
      • You go to Video and set "Recompress" (Fast or Normal, I usually use Normal) or "Full Processing mode" (if you ned to change other parameters of the video, not just compression codec).
      • Set whatever else you need (reading the manuals and FAQs helps).
      • You do File->Save as AVI, and pick a new file name where you want the resulting encoded video to be.
  • Impilse said:
i found the problem between XviD codecs and Adobe Premiere Pro
Go to XviD configuration > Other Options > Encoder and uncheck the "Display encoding status"
  • Anonymous said:
I export to uncompressed avi (or dv avi) it should be really fast then i open the file in autogk and have it do its magic. This is the fastest and easiest way of doing it.

Also on Fandom

Random Wiki